Reply-To with AWS SES doesn't work

I’ve tried setting a reply-to in the designer AWS SES config UI, I’ve also tried setting it in the node api:

channels: {
          email: {
            override: {
              reply_to: ''

And in the Courier logs it shows the Reply-to being set, but SES never sets this header.

I’ve verified the reply-to identify in SES.

Not sure if Courier is using the SES API correctly to set the Reply-To header?

Can anyone else confirm it working?

Hey @dev :wave: - Thanks for reaching out! Requests to SES are working as expected. You can attach a reply-to email through the UI in the delivery channel settings for your notification, or through an override in the request like so:

"providers": {
      "aws-ses": {
        "override": {
          "body": {
            "RawMessage": {
              "Data": "<Mime 1.0 compatible message>"
          "config": {
            "accessKeyId": "<Access Key ID>",
            "secretAccessKey": "<Secret Access Key>"

As you can see from the screenshot, reply to fields are being passed down through AWS SES API.

Thanks for the reply, yes I can see the Reply-To working in the Log Details in Courier, but when the email arrives in my inbox there is no reply-to header. Can you confirm it still works end to end?

Also is it reply_to or replyTo? You have different versions of documentation that have it both ways.

I’m wondering if this is because AWS uses the from address as the default for replying to. Have you tried setting a different reply-to email address in your AWS SES notification? Do you get the same result?

Fiddling with either fails because AWS wants me to verify that email, I just want it as a Reply-To which according to their docs doesn’t require validation